A800 problems!

eKajik 13 Days+ 94

Hey guys, I have bought the 70mai A800 4K dashcam. I have been using it almost daily. For the last month, I have several problems with it, I have tried to contact 70mai support directly - no luck - no answer. 

The camera is restarting itself multiple times after the car starts. Sometimes it just does not record video even when it says that it is recording. 

I have tried multiple microSD cards (yes they have more than enough speed - Sandisk Ultra/Extreme 16/32/64GB tested), I have tried multiple USB cables and even all 12V power sockets. and also power bank - same problems every time. I have also tried to do a factory reset for the camera. 

Anyone else has the same problems? I don't even need to add video - plenty of them on youtube if you search "70mai restarting".

Moreover, since I did not get a reply from the support I will for sure never buy their product again, ever. I just want to know if I can do everything with that camera or just buy a new one from a better brand. Too bad that their SW is crappy since the picture quality is on the better side - but who needs picture quality if the recording is not saved :( 

New Post (1)
  • 1 Quote 2Floor
    I don't know why this is my nick name... :(

    I have the very same issue which I have noticed a few weeks ago and thought it is because of colder weather.
    However, it still does it, usually it happens in the very first seconds after car was started.
    I use hardware kit, I can also hear some power supply noise from the Dashcam, then the 70MAI initial text without the power supply noise, then the camera screen (with noise), then recording, then 70MAI text again... then it starts recording after some bootups.

    I have not experienced this issue earlier, however, it may have appeared after updated it to the latest firmware around the time I have noticed it.

    I think it is a firmware issue and I hope they will repair it...
    6 Days+
Back
Create New Thread